Foxtail Systems Status

Investigating a partial outage in ATL datacenter

resolved

close

investigating

We are currently investigating a partial outage in our ATL datacenter. We will update here shortly when we have more information.